cómo usar sumar.si en google sheets

Cómo utilizar la función SUMAR.SI en las hojas de cálculo de Google

Dentro de las hojas de cálculo de Google una de las funciones más usadas es la de SUMAR, donde sacamos la suma total de los valores de los valores de una columna.

Para ello simplemente ponemos el sigo = para indicar que vamos a escribir una fórmula y a continuación escribimos «SUMA(rango)». Donde «rango» especifica el intervalo de celdas que queremos sumar.

Por ejemplo:

función suma de google sheets

Donde en la celda A9 hemos puesto

=SUMA(A2:A8) 

Para que nos sume todos los valores desde la celda A2 hasta la A8, dando un resultado de 239.

Hasta aquí todo sencillo, pero puede que tengamos una hoja de cálculo donde no tengamos que sumar todos los valores de una columna sino sólo los que cumplan una determinada condición.

Ahí es cuando podemos usar la función SUMAR.SI

Definición de la función SUMAR.SI

Ya sólo el nombre nos da una pista del funcionamiento de la función SUMAR.SI. Va a sumar unos valores si se cumple la condición.

Dependiendo de si tienes la interfaz de las hojas de cálculo de Google en inglés o español, puede que esta función te aparezca como SUMIF.

Cambiar el idioma de las funciones a inglés en las hojas de cálculo de Google

Si quieres usar las fórmulas en inglés a pesar de tener la interfaz en español tienes que ir a «Archivo» > «Configuración»

configuración de google sheets

Y en la ventana que nos aparece marcar la opción de «Usar siempre nombres de función en inglés»

usar funciones de google sheets en inglés

En mi caso, como yo tengo la interfaz en español y quiero usar las funciones en español, no lo tengo marcado.

Sintaxis de SUMAR.SI

La sintaxis de la función de SUMAR.SI es muy sencilla

SUMAR.SI( intervalo; criterio; [intervalo suma])
  • Intervalo: es el rango de celdas que queremos evaluar con «criterio».
  • Criterio: es la condición que tiene que cumplir «intervalo» para que se realice la suma.
  • Inervalo_suma: es un parámetro opcional que se usa cuando los datos a sumar son distintos del rango de «intervalo».

¿Necesitas ayuda con las tareas web de tu negocio?

No permitas que por tener poco tiempo dejes de atender tus clientes como se merecen.

Modo de uso de SUMAR.SI

Para entender mejor cómo funciona la función vamos a verlo en un ejemplo.

Supongamos que hemos apuntado los gastos que hemos hecho en un mes.

gastos del mes

Para obtener información de nuestro listado queremos ir desglosando los gastos y para ello lo primero que queremos saber es cuánto nos hemos gastado en comer fuera de casa.

Así que siguiendo la la sintaxis que hemos visto antes, nos ponemos en la celda donde queremos que aparezca el resultado y escribimos:

=SUMAR.SI(B2:B16;"Comer fuera";C2:C16)
calculo de sumar.si

Que se corresponde con:

  • B2:B16 – El intervalo que queremos evaluar.
  • «Comer fuera» – La condición es que en la celda ponga «Comer fuera». Como es un texto lo ponemos entre comillas («)
  • C2:C16 – El intervalo que tiene que sumar si se cumple la condición.

Uso de SUMAR.SI con números

El parámetro de «criterio» se puede usar con más opciones además de texto.

Vamos a ver un ejemplo con números.

En nuestro ejemplo, vamos a ver cuánto hemos gastado en cantidades por encima de los 20€.

La sintaxis sería:

=SUMAR.SI(C2:C16;">20")
calculo 2 de sumar.si

En ésta ocasión sólo hemos usado 2 parámetros porque el intervalo que se tiene que evaluar y el que se tiene que sumar si cumple el criterio es el mismo.

Uso de SUMAR.SI con fechas

Como hemos visto el parámetro de «criterio» es muy flexible.

Vamos a ver ahora cómo poner una condición de fecha.

En nuestro ejemplo vamos a mostrar ahora lo que hemos gastado en la segunda quincena del mes, así que escribimos la fórmula.

=SUMAR.SI(A2:A16;">15/07/2022";C2:C16)
calculo 3 de sumar.si

En ésta ocasión hemos puesto el intervalo a evaluar el correspondiente a A2:A:16 porque es donde tiene que buscar las fechas y como criterio hemos puesto que la fecha sea mayor al 15 de julio «>15/07/2022».

Uso de SUMAR.SI con comodines

Otra de las opciones que tenemos para usar en el parámetro de «criterio» es poder usar ciertos comodines que sustituyen a ciertos caracteres para ampliar las palabras que buscamos.

  • ? – Sustituye a un carácter en la posición en la que lo pongamos. Por ejemplo «pod?r» daría válido para «podar» o «poder».
  • * – Sustituye a 0 o varios caracteres en la posición en la que lo pongamos. Por ejemplo «Deporte*» daría válido para «Deporte pádel» y «Deporte fútbol».

Si queremos usar los comodines como caracteres reales, no como comodines, tenemos que ponerle delante el carácter de virgulilla (~). De modo que quedaría «~?» o «~*».

Vamos a ver un ejemplo.

Queremos saber cuánto hemos gastado en deporte. Para lo cual usamos la siguiente sintaxis.

=SUMAR.SI(B2:B16;"Deporte*";C2:C16)
calculo 4 sumar.si

Si te das cuenta en el parámetro criterio he puesto «Deporte*» que es como decirle «que el texto empiece por deporte y después que no haya nada o que haya varias letras.»

En el caso de que por error usáramos el «?» no nos daría bien el resultado porque sería como «que el texto empiece por deporte y que haya 1 carácter más».

Nos valdría si buscamos «Deportes» pero no «Deporte fútbol».

Conclusión

Como has podido comprobar la función SUMAR.SI es muy sencilla de usar y nos da más versatilidad a la hora de hacer sumas.

Sólo un para de cosas más para que tengas en cuenta:

  • Mayúsculas y minúsculas: A la hora de buscar por texto, la función no distingue entre mayúsculas y minúsculas así que dará por bueno «deporte» y «DEPORTE».
  • Sólo un criterio de búsqueda: El criterio de la condición lo puedes complicar como quieras pero sólo puede ser uno. O sea, buscar por un número o una palabra. No puedes combinarlo para poner dos condiciones como por ejemplo mostrar los gastos en teatro (criterio 1) que se hayan echo la segunda quincena (criterio 2). Para buscar por más de un criterio tendrías que buscar por otra función, como BDSUMA.

Espero que te sea útil esta función y la uses de ahora en adelante.

¿Necesitas ayuda con las tareas web de tu negocio?

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

Ir arriba